Back to overview
Downtime

Downtime

Nov 18, 2025 at 11:00am UTC
Affected services
App

Resolved
Nov 18, 2025 at 7:38pm UTC

RESOLVED: All services have now recovered and are fully operational.

Updated
Nov 18, 2025 at 4:18pm UTC

UPDATE: We are seeing partial recovery, but are currently experiencing degraded service (partial disruption).

Created
Nov 18, 2025 at 11:00am UTC

We are currently experiencing temporary service disruptions due to an outage at a critical external